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Tip
You can also create a 
paragraph style first within 
the paragraph styles 
panel, then apply the style 
to the paragraph text in 
the document. 

+

Styles
Styles Overview
Styles allow you to define and save the formatting and behaviour of paragraph and character text, objects, cells and 
tables. Using styles is fast and efficient and can save you time by keeping your document formatting more consistent 
and manageable.

Paragraph Style
Paragraph styles apply to the whole paragraph and contain formatting for both the character attributes: font, style, 
leading, tracking & kerning, colour, scale and paragraph attributes: indents & spacing, align, tabs, hyphenation.

Create a paragraph style:
1.	 Start by formatting your text in the document window including the character and paragraph attributes, indents & 

spacing, alignment, colour etc.
2.	 With the text still selected open the paragraph styles panel and select new paragraph style  

from the top right drop-down menu
3.	 Choose a style name
4.	 Click apply style to selection
5.	 Press OK to save a style

Note: You can also create a paragraph style first within the paragraph styles panel, then apply the style to the 
paragraph text in the document. 

Assign paragraph styles to another paragraph:
1.	 With the text tool click into the other paragraph text that you want to apply the style to
2.	 With the paragraph styles panel open click on the style to assign it to the whole paragraph

Character Style
Character styles are similar to paragraph styles, except they only apply to the selected characters  
verses the whole paragraph.

Create a character style:
1.	 Start by formatting your text using the character attributes such as font & style, fill & stroke, leading, tracking and 

kerning
2.	 With the text still selected open the character styles panel and select new character style from the top right drop-

down menu
3.	 Choose a style name
4.	 Click apply style to selection
5.	 Press OK to save a style

Assign character styles to another character:
1.	 With the text tool select the characters (words) that you want  

to apply the character style to
2.	 With the character styles panel open click on the character style  

to assign it to the selected characters
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Edit Styles
Object Style
Object styles allow you to format and save graphics and frames settings including colour 
and stroke, transparency, drop shadows, paragraph styles, frame fitting, text wrap, and 
more. You can choose to apply the effects to the object, fill, stroke, and text.

Create an object style:
1.	 Set the attributes of a object frame in the document window 

including the fill and stroke, corner options, transparency, 
drop shadows, paragraph styles and frame fitting

2.	 With the object still selected open the object styles panel and 
select new object style from the top right drop-down menu

3.	 Choose a style name
4.	 Click apply style to selection in the general tab
5.	 Press OK to save the style

Apply object styles
1.	 Select an object, frame or group that you want to apple the style to
2.	 With the object styles panel open click an object style to apply a style

Redefine Styles [+] 
If you make formatting changes to the text or objects within the 
document a plus [+] sign will appear next to the name of the style. 
The plus [+] indicates that you have changed something about 
the text or object and it no longer matches the original style. 
At this point you have two options, override the style returning 
it back to its original style or updating the original style 
to match your changes which redefines the style.

Override
To clear the changes you made and override and put the text  
or object back to the original style:
1.	 Select the text or object you want to override 
2.	 In the styles panel menu choose clear overrides

Redefine
Alternatively, If you decide you like the changes you made to the text 
or object you can redefine the existing style with the new version.
1.	 Select the text or object that is using the style you want to now use
2.	 In the styles panel menu choose redefine style
The style is updated to match the settings you applied. Any other 
objects using this style in the document are now updated.



Convert text to Table

Convert text Table
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Tables
Understanding Tables
InDesign tables allow you to compare information easier by arranging type into rows and columns. Tables can be 
created from scratch or existing text can be converted into a table. Tables are contained within a text frame.

Create a table from scratch:
1.	 Choose Table > Create Table
2.	 Specify the numbers of rows and columns and press OK
3.	 Drag an area on screen to place and create the table within a text frame

Convert Text to a Table:
1.	 Prepare the text with tabs or commas for the table to be seperated into rows and columns
2.	 Choose Table > Convert Text To Table
3.	 In the column separator and row separator field choose tab, comma, or paragraph option
4.	 Click OK

Monthly Report
Monday	100	 200	 300	 400
Tuesday	1	 2	 3	 4
Wednesday	 10	 20	 30	 40
Thursday	 30	 40	 50	 60
Friday	 1	 2	 3	 4

Monthly Report

Monday 100 200 300 400

Tuesday 1 2 3 4

Wednesday 10 20 30 40

Thursday 30 40 50 60

Friday 1 2 3 4



Number of Rows

Row Height

Column Width

Alignment

Top & Bottom Cell Insert

Table Panel

Left & Right Cell Insert

Rotate Text

Number of Columns

Merge Cells Stroke Weight Cell Stroke proxy preview

Unmerge Cells Stroke Type Table styles
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Editing Tables
Editing Tables
Add text to a table:
1.	 With the type tool selected click inside a cell and start typing 
2.	 To move to the next cell press the tab key 
3.	 To create a new row at the end of the table click in the bottom right cell and press tab 

Add graphics to a table:
1.	 With the text tool selected, click in the table cell that you want to add the image
2.	 Choose File > Place and place the picture into that cell

Merge cells:
1.	 With the type tool select the cells you want to merge
2.	 Choose Table > Merge Cells or click the merge icon in the control panel

Distribute columns and rows evenly:
1.	 With the text tool click and drag in the cells for either columns or rows that that you want to disribute
2.	 Select Table > Distribute Rows Evenly or Distribute Columns Evenly  
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Pages
Working with Pages
The pages panel shows a thumbnail view for each page in your document. Regular pages that make up the document 
are located in the lower half of the pages panel with master pages located in the top section separated by a line. 
Elements placed on a master page will appear on all regular pages in the document that have the master applied. 
Regular pages have an assigned master page prefix letter indicating which master is applied to that page, for example 
[A] Master. 

Create a page
To create a new page do one of the following:
1.	 Click the create new page icon at the bottom right of the pages panel 
2.	 From the pages panel fly-out menu choose number of pages to insert and location
3.	 Right click on a page thumbnail and select insert pages

Delete a page 
To delete a page do one of the following:
4.	 Select the page thumbnail icon and click the bin icon at the bottom right
5.	 Select the page to delete then from the pages panel flyout menu choose delete
6.	 Right click on a page thumbnail and select delete page

Move and insert pages using
To move and insert a page do one of the following:
7.	 With the page thumbnail selected choose move pages from the pages panel fly-out menu and choose a new 

destination. For example, at the beginning of the document.
8.	 In the pages panel drag a page icon to a new position within the document. A vertical line reveals where the page 

will be inserted.
9.	 In the pages panel right click on the page and select move pages, then choose a destination.

Apply master pages:
To apply a master page to a regular page from the top area of the pages panel drag a master page and drop it onto a 
regular page in the lower section of the pages panel. The master page prefix letter will appear on the destination page 
indicating which master is applied.
Adding page numbers:
1.	 Double-click the master page in the pages panel to open it in the document window 
2.	 Create a text frame and position the text where you want the page number to appear
3.	 Option to add text before or after the page number, such as the word page  
4.	 Choose Type > Insert Special Character > Markers > Current Page Number
5.	 Create separate page numbers for the left and right master pages so numbers appear on both sides of the spread

Add running headers:
1.	 Double-click the master page in the pages panel to open it in the document window 
2.	 Add a text frame where you want to add the running header
3.	 With the text selected choose Type > Text Variable >Running Header
4.	 Set the running header style to the paragraph style you want it to follow
5.	 Press OK



Insert Pages Panel

Pages Panel

NewPage Size Bin

Drag to Move Pages

Pages Numbering

Pages Numbers

Pages Menu

Pages Menu

Master Pages

None Page

Regular document Pages

A - Master Page Prefix
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Table of Contents
Creating a Table of Contents (TOC)
A table of contents is used to display a list of chapter titles and page numbers to help readers find information 
throughout a document. To create a table of contents first create paragraph styles for the chapter headings that the 
TOC will use to follow. When generating a table of contents you can set paragraph and character styles to define how 
the table will look. 
Generate a table of contents:
1.	 Create a new page in the document to place the table of contents
2.	 Choose Layout > Table Of Contents
3.	 Choose a title for your TOC which will appear at the top of the table of contents 
4.	 Select the default TOC title style (adds a paragraph style)
5.	 Select the default TOC body style
6.	 Select which styles you want to include in the table of contents paragraph styles in the other styles list and add 

them to the include paragraph styles list
7.	 In the more options section, there are options to add styles for page number and in-between entry and number
8.	 Click OK and place the text on the page you created

Table of contents

Drag style to be included in TOC

Entry Style

TOC Title Default Content heading Style
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Index
Creating an Index
An index is a detailed alphabetical list of names and topics along with the page numbers on which they are 
located. An index entry can consist of a level 1 and level 2 topics and cross-referencing to other index entries 
such as 'see also'.

Create an index: 
1.	 Choose Window > Type & Tables > Index
2.	 Select the text in the document you want to add 
3.	 Click create a new index entry at the bottom of the index panel
4.	 Select or Select All
5.	 press OK

Generate and place the index:
1.	 Create a new page to place the index onto
2.	 Click generate index from the bottom of the index panel
3.	 Choose a default index title style (optional)
4.	 With the loaded cursor place the index

Update the index:
1.	 Add as many new index entries as desired
2.	 re-click generate index
3.	 Press OK and the index will update the currently placed index

Index Entry Panel

Level 1

Level 2

Cross Reference

Index Entry
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Interactivity
Create Hyperlinks
Create hyperlinks to link to external web pages, URLs, email as well as linking to pages and text anchors within an 
InDesign document. Start by creating the destinations within your document, (example: Text Anchor) then create the 
Hyperlinks (buttons) to link to the different destinations.

Create a hyperlink to a web page (URL):
1.	 Select an object to use as the source hyperlink (button)
2.	 Choose new hyperlink from the hyperlinks panel menu
3.	 Choose URL from the link to menu
4.	 Type in a URL web address
5.	 Press OK

Create a page hyperlink:
1.	 Select an object to use as the source hyperlink (button)
2.	 Choose new hyperlink from the hyperlinks panel menu
3.	 Choose page from the link to menu
4.	 Choose the page number and set the zoom level
5.	 Press OK

Create a hyperlink destination (text anchor):
1.	 Using the type tool place the insertion point in the text that you 

want to become a hyperlink destination
2.	 Choose new hyperlink destination from the hyperlinks panel
3.	 Select text anchor from the hyperlink destination panel
4.	 Press OK 

Create a hyperlink:
1.	 Select an object to use as the source hyperlink (button)
2.	 Choose new hyperlink from the hyperlinks panel menu or click the 

create new hyperlink button at the bottom of the hyperlinks panel
3.	 Choose text anchor from the link to menu
4.	 Choose the text anchor destination you created from the text 

anchor menu
5.	 Press OK

Export:
1.	 Choose File > Export > Adobe PDF Print
2.	 Tick the hyperlinks and bookmarks buttons to include

Hyperlink Destination
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Create Buttons
Create a button that navigates to a text anchor, next or previous page, website URL or submit a form. To create buttons 
use the buttons and forms panel. Export a PDF fixed layout EPUB or SWF file.

Create a button:
1.	 Open the buttons and forms panel (choose Window > Interactive > Buttons and forms)
2.	 Create an object and choose Object > Interactive > Convert to Button 
3.	 Choose a name and button type
4.	 Click the add new action icon [+] from the actions area of the buttons and 

forms panel
5.	 Set the appearance for the button states
6.	 Press enter

Create Bookmarks
Create Adobe PDF bookmarks to navigate to pages and text anchors.

Create a bookmark:
1.	 Choose Window > Interactive > Bookmarks to display the bookmarks 

panel
2.	 To create a page bookmark select the page area with the selection tool
3.	 In the bookmark panel click the create new bookmark icon
4.	 To create a text anchor click an insertion point in text
5.	 In the bookmark panel click the create new bookmark icon

Button Types

Button Action

Bookmarks

Include in Export



Continues on 
page 4
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Flowing Text to Multiple Frames
Text can be threaded from one text frame to another. Text frames have in and and out ports allowing you to flow 
the text from one frame to another. You can manually thread the text to each frame or automatically thread longer 
document text to multiple pages by holding the shift key. 

Thread text manually:
1.	 With the selection tool click the red overset text icon to fill load the tool.
2.	 To place the text do one of the following: 
•	 Click and drag in a empty area to create a new text frame 
•	 Hover over an already existing text frame and click to place the text

Thread text automatically:
1.	 Choose file place and select the text file.
2.	 Hover over the text frame (or margin) hold the shift key and place the text. The text then autoflows and creates 

new text frames and new pages as needed.

Show text threads direction line:
Choose View > Extras > Show Text Threading

Text Threading

Re, ipsamen isinus ut 
apicipsapero dolupta 
temquis et experia nissimp 
ossimporibus ma volorios 
dem. Itatur sequi aut 
hicipsamusam facitatur 
ra quosae nonsenias eos 
re et labo. laboriae es 
resed ma cusdaeruptat 
alis eturi,autlabo. endeliq 
uuntibe archil illiquiore vent

Unte des doloris ipienim 
persped esto testior 
errorpore nemod quaerum, 
ex et placest, aut ped qui 
blaborum voloreium lique 
veruptat ditat post, od qui 
ditatis ipist est occaborrum 
is dem dolupicae voluptas et, 
iur re mi, volorem porehentur 
aut audit aliquia tquaeprore 
vent

Text Thread Continue
To allow the threaded text articale to jump from one page to 
another and for the relevant page number to automatically update, 
do the following:

1.	 Create a separate text box underneath the first text frame and 
type the text continues on page

2.	 Choose Type> Insert Special Character> Markers> Next 
Page Number

3.	 Move to the next page where the text threading will continue 
4.	 Create a separate text box underneath the text thread frame 

and type continued from page
5.	 Choose Type> Insert Special Character> Markers> Previous 

Page Number

Insert Next and Previous Page numbers

+
Note
The continue text frames must 
touch their relevant threaded 
text frames for the page 
numbering to display properly.
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Package Panel

Package summary

Preflight Panel

Package

Preflight
Overset text
Overset text error is when the 
text frame is smaller than the 
text. A red plus      appears in 
the lower-right corner of the 
frame, indicating overset text. 
Increase the size of the text 
frame to reveal your text.

+

Package
Package Files
The package command allows you to collect and copy all the linked graphics, fonts and colours to a new folder 
preserving the document. When you use the package command, InDesign checks the entire document and warns
of any errors, which can be fixed using the preflight panel.

To package a document:
1.	 First check the document for any errors using the preflight panel (Window > Output > Preflight)
2.	 Choose File > Package
3.	 The package dialog box opens where you can fill in any printing instructions
4.	 Click continue, and choose a location where you want to save the packaged files
5.	 A warning message appears to check any font licence agreement restrictions before sharing fonts 
6.	 Click package

Overset text error on page 21

Package dialog box



Save and Export Your Document as a PDF
To save your InDesign document:
1.	 Choose File > Save as
2.	 Give your document a title
3.	 Choose Format > InDesign CC 2018 document 
Note: Format options allow you to save your document as a template or for an older version  
of InDesign.

To export your InDesign document:

To share your finished document export a PDF

1.	 Choose File > Export
2.	 Name the file, choose Adobe PDF (Print) for the format option 
3.	 Click save and in the export Adobe PDF preset dialog box that appears do one of the following:
4.	 To print on a desktop digital printer choose High quality print from the Adobe PDF preset dialogue box
5.	 To email your document choose smallest file size from the Adobe PDF preset dialogue box
6.	 Click export to output the PDF

Note: To convert all your images from CMYK to RGB or vice versa go to output setting within the export panel and 
choose convert to destination

Export settings panel
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Save and Export
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